US Region - Email Delivery Issue

Incident Report for Deque Services Health and Status

Monitoring

We have implemented a fix and the issue appears to be mitigated. We are continuing to monitor. Please contact Support with any issues.
Posted Jan 25, 2026 - 23:17 EST

Update

We are continuing to work on a fix for this issue.
Posted Jan 25, 2026 - 23:14 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 25, 2026 - 19:26 EST

Investigating

We are currently investigating an issue that may be preventing the delivery of emails from Deque products hosted in our US region.

This may affect delivery of new user provisioning invitation emails and other email notifications sent by our products. We are working on a mitigation and hope to have this resolved as soon as possible.
Posted Jan 25, 2026 - 19:26 EST
This incident affects: Axe Devtools Pro Server, Axe Monitor, and Axe Auditor.