Deque | SSO Access Issues

Incident Report for Deque Services Health and Status

Resolved

This incident has been resolved.

For any questions or assistance, please reach out to us at helpdesk@deque.com.
Posted Feb 25, 2026 - 05:15 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 25, 2026 - 05:13 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 19, 2026 - 09:25 EST

Identified

We have identified a fix for the SSO login issues some customers experienced earlier today. We are currently testing the solution and, if successful, will roll it out to all impacted customers.

We apologize for any disruption this may have caused. For any questions or further assistance, don't hesitate to get in touch with helpdesk@deque.com.
Posted Feb 17, 2026 - 16:46 EST

Investigating

We are aware that some of our customers are currently experiencing difficulties accessing Deque products via SSO. Our engineering team is actively investigating and working on a resolution.

We apologize for the inconvenience and will provide further updates as the situation progresses. For any questions or assistance, please reach out to us at helpdesk@deque.com.
Posted Feb 17, 2026 - 09:31 EST
This incident affected: Deque Log-In Service (US).