Deque University | Outage | Service Restored (3/10/2025)

Incident Report for Deque Services Health and Status

Resolved

This incident has been resolved.
Posted 3 months ago. Mar 17, 2025 - 10:02 EDT

Investigating

Deque University experienced an outage from 12:25:06 AM to 12:43 AM EST (3/10/2025). The service is now fully restored, and our team is currently investigating the exact root cause. We will provide further updates as more details become available.

We apologize for any inconvenience and appreciate your patience. For any further queries, please reach out to helpdesk@deque.com.
Posted 3 months ago. Mar 11, 2025 - 01:28 EDT
This incident affected: Deque University.