Slowness Loading Projects in Dev Hub

Incident Report for Deque Services Health and Status

Resolved

Performance has remained consistent; this incident is resolved.
Posted Nov 05, 2025 - 09:42 EST

Monitoring

A fix has been implemented and we have noticed immediate improvement. We will continue to monitor performance.
Posted Nov 04, 2025 - 17:12 EST

Investigating

We have identified performance degradation in loading projects within Axe Developer Hub. We have identified a fix and are preparing it for deployment.
Posted Nov 04, 2025 - 16:57 EST